In short
- CVE-2021-43045 is a HIGH (CVSS 7.5) vulnerability affecting Apache.Avro, avro (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.1%, higher than 87.6% of all vulnerabilities.
- Fix: update to 1.11.0 or later.
| Package | Affected versions | Patched versions |
|---|
| Apache.Avro NuGet | < 1.11.0
| 1.11.0
|
| avro | < 1.11.0
| 1.11.0
|
Description
A vulnerability in the .NET SDK of Apache Avro allows an attacker to allocate excessive resources, potentially causing a denial-of-service attack. This issue affects .NET applications using Apache Avro version 1.10.2 and prior versions. Users should update to version 1.11.0 which addresses this issue.
NVD description
A vulnerability in the .NET SDK of Apache Avro allows an attacker to allocate excessive resources, potentially causing a denial-of-service attack. This issue affects .NET applications using Apache Avro version 1.10.2 and prior versions. Users should update to version 1.11.0 which addresses this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free