| Package | Affected versions | Patched versions |
|---|---|---|
| async | ≥ 3.0.0, < 3.2.2< 2.6.4 | 3.2.22.6.4 |
| async | ≥ 2.0.0, < 2.6.4≥ 3.0.0, < 3.2.2 | 2.6.43.2.2 |
A vulnerability exists in Async through 3.2.1 for 3.x and through 2.6.3 for 2.x (fixed in 3.2.2 and 2.6.4), which could let a malicious user obtain privileges via the mapValues() method.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free