In short
- CVE-2021-43307 is a HIGH (CVSS 7.5) vulnerability affecting semver-regex (semver-regex project), semver-regex.
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.3% of all vulnerabilities.
- Fix: update to 4.0.3, 3.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| semver-regex | ≥ 4.0.0, < 4.0.3< 3.1.4
| 4.0.33.1.4
|
| semver-regex npm | ≥ 4.0.0, < 4.0.3< 3.1.4
| 4.0.33.1.4
|
Description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the semver-regex npm package, when an attacker is able to supply arbitrary input to the test() method
NVD description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the semver-regex npm package, when an attacker is able to supply arbitrary input to the test() method
More vulnerabilities in semver-regex
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free