In short
- CVE-2021-43415 is a HIGH (CVSS 8.8) vulnerability affecting github.com/hashicorp/nomad, nomad (hashicorp).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.6% of all vulnerabilities.
- Fix: update to 1.1.8, 1.2.1, 1.0.14 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/nomad Go | ≥ 1.1.0, < 1.1.8≥ 1.2.0, < 1.2.1< 1.0.14
| 1.1.81.2.11.0.14
|
| nomad | = 1.2.0≥ 1.0.0, < 1.0.14≥ 1.1.0, < 1.1.8
| 1.0.141.1.8
|
Description
HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task driver enabled, allowed authenticated users with job submission capabilities to bypass the configured allowed image paths. Fixed in 1.0.14, 1.1.8, and 1.2.1.
NVD description
HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task driver enabled, allowed authenticated users with job submission capabilities to bypass the configured allowed image paths. Fixed in 1.0.14, 1.1.8, and 1.2.1.
More vulnerabilities in github.com/hashicorp/nomad
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free