In short
- CVE-2021-45230 is a MEDIUM (CVSS 6.5) vulnerability affecting apache-airflow, airflow (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.3% of all vulnerabilities.
- Fix: update to 2.0.0b1, 2.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 1.10.0, < 2.0.0b1≥ 2.0.0, < 2.2.0< 2.2.0
| 2.0.0b12.2.0
|
| airflow | ≥ 1.10.0, ≤ 1.10.15≥ 2.0.0, < 2.2.0
| 2.2.0
|
Description
In Apache Airflow prior to 2.2.0. This CVE applies to a specific case where a User who has "can_create" permissions on DAG Runs can create Dag Runs for dags that they don't have "edit" permissions for.
NVD description
In Apache Airflow prior to 2.2.0. This CVE applies to a specific case where a User who has "can_create" permissions on DAG Runs can create Dag Runs for dags that they don't have "edit" permissions for.
More vulnerabilities in apache-airflow
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free