In short
- CVE-2021-45458 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.kylin:kylin, kylin (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 82.1% of all vulnerabilities.
- Fix: update to 4.0.1, 3.1.3 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.kylin:kylin Maven | ≥ 4.0.0, < 4.0.1< 3.1.3
| 4.0.13.1.3
|
| kylin | = 4.0.0≥ 2.0.0, ≤ 2.6.6≥ 3.0.0, < 3.1.3
| 3.1.3
|
Description
Apache Kylin provides encryption classes PasswordPlaceholderConfigurer to help users encrypt their passwords. In the encryption algorithm used by this encryption class, the cipher is initialized with a hardcoded key and IV. If users use class PasswordPlaceholderConfigurer to encrypt their password and configure it into kylin's configuration file, there is a risk that the password may be decrypted. This issue affects Apache Kylin 2 version 2.6.6 and prior versions; Apache Kylin 3 version 3.1.2 and prior versions; Apache Kylin 4 version 4.0.0 and prior versions.
NVD description
Apache Kylin provides encryption classes PasswordPlaceholderConfigurer to help users encrypt their passwords. In the encryption algorithm used by this encryption class, the cipher is initialized with a hardcoded key and IV. If users use class PasswordPlaceholderConfigurer to encrypt their password and configure it into kylin's configuration file, there is a risk that the password may be decrypted. This issue affects Apache Kylin 2 version 2.6.6 and prior versions; Apache Kylin 3 version 3.1.2 and prior versions; Apache Kylin 4 version 4.0.0 and prior versions.
More vulnerabilities in org.apache.kylin:kylin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free