In short
- CVE-2021-45958 is a MEDIUM (CVSS 5.5) vulnerability affecting ujson, ultrajson (ultrajson project).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 76.8% of all vulnerabilities.
- Fix: update to 5.2.0, 5.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ujson PyPI | ≥ 1.34, < 5.2.0≥ 4.0.2, < 5.1.0
| 5.2.05.1.0
|
| ultrajson | < 5.2.0
| 5.2.0
|
Description
UltraJSON (aka ujson) 1.34 through 5.1.0 has a stack-based buffer overflow in Buffer_AppendIndentUnchecked (called from encode).
NVD description
UltraJSON (aka ujson) through 5.1.0 has a stack-based buffer overflow in Buffer_AppendIndentUnchecked (called from encode). Exploitation can, for example, use a large amount of indentation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free