In short
- CVE-2021-46440 is a HIGH (CVSS 7.5) vulnerability affecting strapi (strapi), @strapi/strapi, strapi.
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 86.9% of all vulnerabilities.
- Fix: update to 4.1.5, 3.6.9 or later.
| Package | Affected versions | Patched versions |
|---|
| strapi | ≥ 4.0.0, < 4.1.5< 3.6.9
| 4.1.53.6.9
|
| @strapi/strapi npm | ≥ 4.0.0, < 4.1.5
| 4.1.5
|
| strapi npm | < 3.6.9
| 3.6.9
|
Description
Storing passwords in a recoverable format in the DOCUMENTATION plugin component of Strapi before 3.6.9 and 4.x before 4.1.5 allows an attacker to access a victim's HTTP request. From this, the attacker can get the victim's cookie, base64 decode it, and obtain a cleartext password, leading to getting API documentation for further API attacks.
NVD description
Storing passwords in a recoverable format in the DOCUMENTATION plugin component of Strapi before 3.6.9 and 4.x before 4.1.5 allows an attacker to access a victim's HTTP request, get the victim's cookie, perform a base64 decode on the victim's cookie, and obtain a cleartext password, leading to getting API documentation for further API attacks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free