In short
- CVE-2021-46704 is a CRITICAL (CVSS 9.8) vulnerability affecting genieacs (genieacs), genieacs.
- Chance of exploitation in the next 30 days (EPSS): 21.9%, higher than 97.6% of all vulnerabilities.
- Fix: update to 1.2.8 or later.
| Package | Affected versions | Patched versions |
|---|
| genieacs | ≥ 1.2.0, < 1.2.8
| 1.2.8
|
| genieacs npm | < 1.2.8
| 1.2.8
|
Description
In GenieACS 1.2.x before 1.2.8, the UI interface API is vulnerable to unauthenticated OS command injection via the ping host argument (lib/ui/api.ts and lib/ping.ts). The vulnerability arises from insufficient input validation combined with a missing authorization check.
NVD description
In GenieACS 1.2.x before 1.2.8, the UI interface API is vulnerable to unauthenticated OS command injection via the ping host argument (lib/ui/api.ts and lib/ping.ts). The vulnerability arises from insufficient input validation combined with a missing authorization check.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free