In short
- CVE-2021-47935 is a HIGH (CVSS 8.8) vulnerability affecting sentry, sentry (sentry).
- Chance of exploitation in the next 30 days (EPSS): 0.93%, higher than 60.5% of all vulnerabilities.
- Fix: update to 8.2.2, 8.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| sentry PyPI | ≥ 8.2.0, < 8.2.2≤ 8.2.0< 8.1.4
| 8.2.28.1.4
|
| sentry | = 8.2.0
| No fix yet |
Description
Sentry 8.2.0 contains a remote code execution vulnerability that allows authenticated superusers to execute arbitrary commands by injecting malicious pickle-serialized objects through the audit log entry data parameter. Attackers can submit crafted POST requests to the admin audit log endpoint with base64-encoded compressed pickle payloads in the data field to achieve code execution with application privileges.
NVD description
Sentry 8.2.0 contains a remote code execution vulnerability that allows authenticated superusers to execute arbitrary commands by injecting malicious pickle-serialized objects through the audit log entry data parameter. Attackers can submit crafted POST requests to the admin audit log endpoint with base64-encoded compressed pickle payloads in the data field to achieve code execution with application privileges.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free