In short
- CVE-2022-1962 is a MEDIUM (CVSS 5.5) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 0.92%, higher than 60.2% of all vulnerabilities.
- Fix: update to 1.18.4, 1.17.12 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.18.0-0, < 1.18.4< 1.17.12
| 1.18.41.17.12
|
| go | ≥ 1.18.0, < 1.18.4< 1.17.12
| 1.18.41.17.12
|
Description
Calling any of the Parse functions on Go source code which contains deeply nested types or declarations can cause a panic due to stack exhaustion.
NVD description
Uncontrolled recursion in the Parse functions in go/parser before Go 1.17.12 and Go 1.18.4 allow an attacker to cause a panic due to stack exhaustion via deeply nested types or declarations.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free