In short
- CVE-2022-20617 is a HIGH (CVSS 8.8) vulnerability affecting org.jenkins-ci.plugins:docker-commons, docker commons (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.0% of all vulnerabilities.
- Fix: update to 1.18 or later.
Description
Jenkins Docker Commons Plugin 1.17 and earlier does not sanitize the name of an image or a tag, resulting in an OS command execution vulnerability exploitable by attackers with Item/Configure permission or able to control the contents of a previously configured job's SCM repository.
NVD description
Jenkins Docker Commons Plugin 1.17 and earlier does not sanitize the name of an image or a tag, resulting in an OS command execution vulnerability exploitable by attackers with Item/Configure permission or able to control the contents of a previously configured job's SCM repository.
More vulnerabilities in org.jenkins-ci.plugins:docker-commons
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free