In short
- CVE-2022-21122 is a CRITICAL (CVSS 9.8) vulnerability affecting metacalc (metarhia), metacalc.
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 85.9% of all vulnerabilities.
- Fix: update to 0.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| metacalc | < 0.0.2
| 0.0.2
|
| metacalc npm | < 0.0.2
| 0.0.2
|
Description
The package metacalc before 0.0.2 is vulnerable to Arbitrary Code Execution when it exposes JavaScript's Math class to the v8 context. As the Math class is exposed to user-land, it can be used to get access to JavaScript's Function constructor.
NVD description
The package metacalc before 0.0.2 are vulnerable to Arbitrary Code Execution when it exposes JavaScript's Math class to the v8 context. As the Math class is exposed to user-land, it can be used to get access to JavaScript's Function constructor.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free