In short
- CVE-2022-21187 is a CRITICAL (CVSS 9.8) vulnerability affecting libvcs, vcspull, libvcs (libvcs project).
- Chance of exploitation in the next 30 days (EPSS): 3.6%, higher than 89.6% of all vulnerabilities.
- Fix: update to 0.11.1, 1.11.1 or later.
| Package | Affected versions | Patched versions |
|---|
| libvcs PyPI | < 0.11.1
| 0.11.1
|
| vcspull PyPI | < 1.11.1
| 1.11.1
|
| libvcs | < 0.11.1
| 0.11.1
|
Description
The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.
NVD description
The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free