In short
- CVE-2022-21221 is a HIGH (CVSS 7.5) vulnerability affecting github.com/valyala/fasthttp, fasthttp (fasthttp project).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.8% of all vulnerabilities.
- Fix: update to 1.34.0 or later.
Description
The package github.com/valyala/fasthttp before 1.34.0 is vulnerable to Directory Traversal via the ServeFile function, due to improper sanitization. It is possible to be exploited by using a backslash %5c character in the path. Note: This security issue impacts Windows users only.
NVD description
The package github.com/valyala/fasthttp before 1.34.0 are vulnerable to Directory Traversal via the ServeFile function, due to improper sanitization. It is possible to be exploited by using a backslash %5c character in the path. **Note:** This security issue impacts Windows users only.
More vulnerabilities in github.com/valyala/fasthttp
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free