In short
- CVE-2022-21712 is a HIGH (CVSS 7.5) vulnerability affecting twisted, twisted (twisted).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.1% of all vulnerabilities.
- Fix: update to 22.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| twisted PyPI | ≥ 11.1.0, < 22.1.0
| 22.1.0
|
| twisted | ≥ 11.1.0, < 22.1.0
| 22.1.0
|
Description
Impact
Cookie and Authorization headers are leaked when following cross-origin redirects in twited.web.client.RedirectAgent and twisted.web.client.BrowserLikeRedirectAgent.
NVD description
twisted is an event-driven networking engine written in Python. In affected versions twisted exposes cookies and authorization headers when following cross-origin redirects. This issue is present in the `twited.web.RedirectAgent` and `twisted.web. BrowserLikeRedirectAgent` functions. Users are advised to upgrade. There are no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free