In short
- CVE-2022-21797 is a CRITICAL (CVSS 9.8) vulnerability affecting joblib, joblib (joblib project).
- Chance of exploitation in the next 30 days (EPSS): 2.6%, higher than 85.6% of all vulnerabilities.
- Fix: update to 1.2.0, 1.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| joblib PyPI | < 1.2.0
| 1.2.0
|
| joblib | < 1.1.1
| 1.1.1
|
Description
The package joblib from 0 and before 1.2.0 is vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement.
NVD description
The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free