In short
- CVE-2022-21802 is a MEDIUM (CVSS 6.1) vulnerability affecting grapesjs (grapesjs), grapesjs.
- Chance of exploitation in the next 30 days (EPSS): 0.80%, higher than 56.7% of all vulnerabilities.
- Fix: update to 0.19.5 or later.
| Package | Affected versions | Patched versions |
|---|
| grapesjs | < 0.19.5
| 0.19.5
|
| grapesjs npm | all versions
| No fix yet |
Description
The package grapesjs before 0.19.5 is vulnerable to Cross-site Scripting (XSS) due to an improper sanitization of the class name in Selector Manager.
NVD description
The package grapesjs before 0.19.5 are vulnerable to Cross-site Scripting (XSS) due to an improper sanitization of the class name in Selector Manager.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free