In short
- CVE-2022-21803 is a HIGH (CVSS 7.5) vulnerability affecting nconf (nconf project), nconf.
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.4% of all vulnerabilities.
- Fix: update to 0.11.4 or later.
| Package | Affected versions | Patched versions |
|---|
| nconf | < 0.11.4
| 0.11.4
|
| nconf npm | < 0.11.4
| 0.11.4
|
Description
nconf before 0.11.4. When using the memory engine, it is possible to store a nested JSON representation of the configuration. The .set() function, that is responsible for setting the configuration properties, is vulnerable to Prototype Pollution. By providing a crafted property, it is possible to modify the properties on the Object.prototype.
NVD description
This affects the package nconf before 0.11.4. When using the memory engine, it is possible to store a nested JSON representation of the configuration. The .set() function, that is responsible for setting the configuration properties, is vulnerable to Prototype Pollution. By providing a crafted property, it is possible to modify the properties on the Object.prototype.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free