In short
- CVE-2022-2255 is a HIGH (CVSS 7.5) vulnerability affecting mod-wsgi, mod wsgi (modwsgi).
- Chance of exploitation in the next 30 days (EPSS): 0.94%, higher than 61.1% of all vulnerabilities.
- Fix: update to 4.9.3 or later.
| Package | Affected versions | Patched versions |
|---|
| mod-wsgi PyPI | < 4.9.3
| 4.9.3
|
| mod wsgi | < 4.9.3
| 4.9.3
|
Description
A vulnerability was found in mod_wsgi. The X-Client-IP header is not removed from a request from an untrusted proxy, allowing an attacker to pass the X-Client-IP header to the target WSGI application because the condition to remove it is missing.
NVD description
A vulnerability was found in mod_wsgi. The X-Client-IP header is not removed from a request from an untrusted proxy, allowing an attacker to pass the X-Client-IP header to the target WSGI application because the condition to remove it is missing.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free