In short
- CVE-2022-2256 is a LOW (CVSS 3.8) vulnerability affecting org.keycloak:keycloak-parent, single sign-on (redhat).
- Chance of exploitation in the next 30 days (EPSS): 0.70%, higher than 53.0% of all vulnerabilities.
- Fix: update to 19.0.2 or later.
Description
A Stored XSS vulnerability was reported in the Keycloak Security mailing list, affecting all the versions of Keycloak, including the latest release (18.0.1). The vulnerability allows a privileged attacker to execute malicious scripts in the admin console, abusing of the default roles functionality.
CVSS 3.1 - 3.8
Vector String: AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Vector Clarification:
- User interaction is not required as the admin console is regularly used during an administrator's work
- The scope is unchanged since the admin console web application is both the vulnerable component and where the exploit executes
Credits
Aytaç Kalıncı, Ilker Bulgurcu, Yasin Yılmaz (@aytackalinci, @smileronin, @yasinyilmaz) - NETAŞ PENTEST TEAM
NVD description
A Stored Cross-site scripting (XSS) vulnerability was found in keycloak as shipped in Red Hat Single Sign-On 7. This flaw allows a privileged attacker to execute malicious scripts in the admin console, abusing the default roles functionality.
More vulnerabilities in org.keycloak:keycloak-parent
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free