In short
- CVE-2022-22846 is a MEDIUM (CVSS 5.3) vulnerability affecting dnslib, dnslib (dnslib project).
- Chance of exploitation in the next 30 days (EPSS): 0.87%, higher than 59.1% of all vulnerabilities.
- Fix: update to 0.9.17 or later.
| Package | Affected versions | Patched versions |
|---|
| dnslib PyPI | < 0.9.17
| 0.9.17
|
| dnslib | ≤ 0.9.16
| No fix yet |
Description
The dnslib package through 0.9.16 for Python does not verify that the ID value in a DNS reply matches an ID value in a query.
NVD description
The dnslib package through 0.9.16 for Python does not verify that the ID value in a DNS reply matches an ID value in a query.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free