In short
- CVE-2022-23108 is a MEDIUM (CVSS 5.4) vulnerability affecting org.jenkins-ci.plugins:badge, badge (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.84%, higher than 58.0% of all vulnerabilities.
- Fix: update to 1.9.1 or later.
Description
Jenkins Badge Plugin 1.9 and earlier does not escape the description and does not check for allowed protocols when creating a badge, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
NVD description
Jenkins Badge Plugin 1.9 and earlier does not escape the description and does not check for allowed protocols when creating a badge, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
More vulnerabilities in org.jenkins-ci.plugins:badge
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free