In short
- CVE-2022-23109 is a MEDIUM (CVSS 6.5) vulnerability affecting com.datapipe.jenkins.plugins:hashicorp-vault-plugin, hashicorp vault (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.96%, higher than 61.5% of all vulnerabilities.
- Fix: update to 3.8.0 or later.
Description
Jenkins HashiCorp Vault Plugin 3.7.0 and earlier does not mask Vault credentials in Pipeline build logs or in Pipeline step descriptions when Pipeline: Groovy Plugin 2.85 or later is installed.
NVD description
Jenkins HashiCorp Vault Plugin 3.7.0 and earlier does not mask Vault credentials in Pipeline build logs or in Pipeline step descriptions when Pipeline: Groovy Plugin 2.85 or later is installed.
More vulnerabilities in com.datapipe.jenkins.plugins:hashicorp-vault-plugin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free