In short
- CVE-2022-23437 is a MEDIUM (CVSS 6.5) vulnerability affecting xerces:xercesImpl, xerces-j (apache), agile engineering data management (oracle).
- Chance of exploitation in the next 30 days (EPSS): 11.6%, higher than 96.0% of all vulnerabilities.
- Fix: update to 2.12.2, 9.0, 8.1.2.0, 13.9.4.2.2 or later.
Description
There's a vulnerability within the Apache Xerces Java (XercesJ) XML parser when handling specially crafted XML document payloads. This causes, the XercesJ XML parser to wait in an infinite loop, which may sometimes consume system resources for prolonged duration. This vulnerability is present within XercesJ version 2.12.1 and the previous versions.
NVD description
There's a vulnerability within the Apache Xerces Java (XercesJ) XML parser when handling specially crafted XML document payloads. This causes, the XercesJ XML parser to wait in an infinite loop, which may sometimes consume system resources for prolonged duration. This vulnerability is present within XercesJ version 2.12.1 and the previous versions.
More vulnerabilities in xerces:xercesImpl
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free