In short
- CVE-2022-23476 is a HIGH (CVSS 7.5) vulnerability affecting nokogiri, nokogiri (nokogiri).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.8% of all vulnerabilities.
- Fix: update to 1.13.10 or later.
| Package | Affected versions | Patched versions |
|---|
| nokogiri RubyGems | ≥ 1.13.8, < 1.13.10
| 1.13.10
|
| nokogiri | = 1.13.8= 1.13.9
| No fix yet |
Description
Summary
Nokogiri 1.13.8, 1.13.9 fails to check the return value from xmlTextReaderExpand in the method Nokogiri::XML::Reader#attribute_hash. This can lead to a null pointer exception when invalid markup is being parsed.
For applications using XML::Reader to parse untrusted inputs, this may potentially be a vector for a denial of service attack.
Mitigation
Upgrade to Nokogiri >= 1.13.10.
Users may be able to search their code for calls to either XML::Reader#attributes or XML::Reader#attribute_hash to determine if they are affected.
Severity
The Nokogiri maintainers have evaluated this as High Severity 7.5 (CVSS3.1).
References
Credit
This vulnerability was responsibly reported by @davidwilemski.
NVD description
Nokogiri is an open source XML and HTML library for the Ruby programming language. Nokogiri `1.13.8` and `1.13.9` fail to check the return value from `xmlTextReaderExpand` in the method `Nokogiri::XML::Reader#attribute_hash`. This can lead to a null pointer exception when invalid markup is being parsed. For applications using `XML::Reader` to parse untrusted inputs, this may potentially be a vector for a denial of service attack. Users are advised to upgrade to Nokogiri `>= 1.13.10`. Users may be able to search their code for calls to either `XML::Reader#attributes` or `XML::Reader#attribute_hash` to determine if they are affected.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free