In short
- CVE-2022-23496 is a HIGH (CVSS 7.5) vulnerability affecting nl.basjes.parse.useragent:yauaa, nl.basjes.parse.useragent:yauaa-beam, nl.basjes.parse.useragent:yauaa-beam-sql.
- Chance of exploitation in the next 30 days (EPSS): 0.80%, higher than 56.9% of all vulnerabilities.
- Fix: update to 7.9.0 or later.
Description
Impact
Applications using the Client Hints analysis feature introduced with 7.0.0 can crash because the Yauaa library throws an ArrayIndexOutOfBoundsException. Applications that do not use this feature are not affected.
Patches
Upgrade to 7.9.0
Workarounds
Catch and discard any exceptions from Yauaa.
NVD description
Yet Another UserAgent Analyzer (Yauaa) is a java library that tries to parse and analyze the useragent string and extract as many relevant attributes as possible. Applications using the Client Hints analysis feature introduced with 7.0.0 can crash because the Yauaa library throws an ArrayIndexOutOfBoundsException. If uncaught the exception will result in a program crash. Applications that do not use this feature are not affected. Users are advised to upgrade to version 7.9.0. Users unable to upgrade may catch and discard any ArrayIndexOutOfBoundsException thrown by the Yauaa library.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free