In short
- CVE-2022-23542 is a CRITICAL (CVSS 9.8) vulnerability affecting github.com/openfga/openfga, openfga (openfga).
- Chance of exploitation in the next 30 days (EPSS): 0.99%, higher than 62.5% of all vulnerabilities.
- Fix: update to 0.3.1 or later.
Description
Overview
During our internal security assessment, it was discovered that OpenFGA versions v0.3.0 is vulnerable to authorization bypass under certain conditions.
Am I Affected?
You are affected by this vulnerability if all of the following applies:
- You are using OpenFGA v0.3.0
- You created a model using modeling language v1.1 that applies a type restriction to an object e.g.
define viewer: [user]
- You created tuples based on the aforementioned model, e.g.
document:1#viewer@user:jon
- You updated the previous model by adding a new type and replacing the previous restriction with the newly added type e.g.
define viewer: [employee]
- You use the tuples created against the first model (step 3) and issue checks against the updated model e.g.
user=user:jon, relation=viewer, object:document:1
How to fix that?
Upgrade to version v0.3.1
Backward Compatibility
This update is backward compatible.
NVD description
OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. During an internal security assessment, it was discovered that OpenFGA version 0.3.0 is vulnerable to authorization bypass under certain conditions. This issue has been patched in version 0.3.1 and is backward compatible.
More vulnerabilities in github.com/openfga/openfga
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free