In short
- CVE-2022-23615 is a MEDIUM (CVSS 5.4) vulnerability affecting org.xwiki.platform:xwiki-platform-oldcore, xwiki (xwiki).
- Chance of exploitation in the next 30 days (EPSS): 0.68%, higher than 52.6% of all vulnerabilities.
- Fix: update to 13.0 or later.
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with SCRIPT right (EDIT right before XWiki 7.4) can save a document with the right of the current user which allow accessing API requiring programming right if the current user has programming right. It has been patched in XWiki 13.0. The only workaround is to give SCRIPT right only to trusted users.
NVD description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions any user with SCRIPT right can save a document with the right of the current user which allow accessing API requiring programming right if the current user has programming right. This has been patched in XWiki 13.0. Users are advised to update to resolve this issue. The only known workaround is to limit SCRIPT access.
More vulnerabilities in org.xwiki.platform:xwiki-platform-oldcore
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free