In short
- CVE-2022-23772 is a HIGH (CVSS 7.5) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.5% of all vulnerabilities.
- Fix: update to 1.17.7, 1.16.14 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.17.0-0, < 1.17.7< 1.16.14
| 1.17.71.16.14
|
| go | ≥ 1.17.0, < 1.17.7< 1.16.14
| 1.17.71.16.14
|
Description
Rat.SetString had an overflow issue that can lead to uncontrolled memory consumption.
NVD description
Rat.SetString in math/big in Go before 1.16.14 and 1.17.x before 1.17.7 has an overflow that can lead to Uncontrolled Memory Consumption.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free