In short
- CVE-2022-23942 is a HIGH (CVSS 7.5) vulnerability affecting pydoris, doris (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 88.7% of all vulnerabilities.
- Fix: update to 1.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pydoris PyPI | < 1.0.0
| 1.0.0
|
| doris | < 1.0.0
| 1.0.0
|
Description
Apache Doris, prior to 1.0.0, used a hardcoded key and IV to initialize the cipher used for ldap password, which may lead to information disclosure.
NVD description
Apache Doris, prior to 1.0.0, used a hardcoded key and IV to initialize the cipher used for ldap password, which may lead to information disclosure.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free