In short
- CVE-2022-24279 is a HIGH (CVSS 7.5) vulnerability affecting madlib-object-utils (springtree), madlib-object-utils.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.4% of all vulnerabilities.
- Fix: update to 0.1.8 or later.
Description
The package madlib-object-utils before version 0.1.8 is vulnerable to Prototype Pollution via the setValue method, as it allows an attacker to merge object prototypes into it. Note: This vulnerability derives from an incomplete fix of CVE-2020-7701
NVD description
The package madlib-object-utils before 0.1.8 are vulnerable to Prototype Pollution via the setValue method, as it allows an attacker to merge object prototypes into it. *Note:* This vulnerability derives from an incomplete fix of [CVE-2020-7701](https://security.snyk.io/vuln/SNYK-JS-MADLIBOBJECTUTILS-598676)
More vulnerabilities in madlib-object-utils
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free