In short
- CVE-2022-24294 is a HIGH (CVSS 7.5) vulnerability affecting mxnet, mxnet (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.6% of all vulnerabilities.
- Fix: update to 1.9.1 or later.
| Package | Affected versions | Patched versions |
|---|
| mxnet PyPI | < 1.9.1
| 1.9.1
|
| mxnet | < 1.9.1
| 1.9.1
|
Description
A regular expression used in Apache MXNet (incubating) is vulnerable to a potential denial-of-service by excessive resource consumption. The bug could be exploited when loading a model in Apache MXNet that has a specially crafted operator name that would cause the regular expression evaluation to use excessive resources to attempt a match. This issue affects Apache MXNet versions prior to 1.9.1.
NVD description
A regular expression used in Apache MXNet (incubating) is vulnerable to a potential denial-of-service by excessive resource consumption. The bug could be exploited when loading a model in Apache MXNet that has a specially crafted operator name that would cause the regular expression evaluation to use excessive resources to attempt a match. This issue affects Apache MXNet versions prior to 1.9.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free