In short
- CVE-2022-24615 is a MEDIUM (CVSS 5.5) vulnerability affecting net.lingala.zip4j:zip4j, zip4j (zip4j project).
- Chance of exploitation in the next 30 days (EPSS): 0.71%, higher than 53.5% of all vulnerabilities.
- Fix: update to 2.10.0 or later.
Description
zip4j up to 2.9.1 can throw various uncaught exceptions while parsing a specially crafted ZIP file, which could result in an application crash. This could be used to mount a denial of service attack against services that use zip4j library.
NVD description
zip4j up to v2.10.0 can throw various uncaught exceptions while parsing a specially crafted ZIP file, which could result in an application crash. This could be used to mount a denial of service attack against services that use zip4j library.
More vulnerabilities in net.lingala.zip4j:zip4j
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free