| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/hashicorp/nomad | ≥ 0.9.0, < 1.0.18≥ 1.1.0, < 1.1.12≥ 1.2.0, < 1.2.6 | 1.0.181.1.121.2.6 |
| nomad | ≥ 0.9.0, < 1.0.18≥ 1.1.0, < 1.1.12≥ 1.2.0, < 1.2.6 | 1.0.181.1.121.2.6 |
Nomad and Nomad Enterprise allows operators with job-submit capabilities to use the spread stanza in a way such that it can cause panic in Nomad servers. This vulnerability, CVE-2022-24684, was fixed in Nomad 1.0.18, 1.1.12, and 1.2.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free