In short
- CVE-2022-24709 is a MEDIUM (CVSS 6.1) vulnerability affecting awsui/components-react (amazon), @awsui/components-react.
- Chance of exploitation in the next 30 days (EPSS): 0.69%, higher than 52.9% of all vulnerabilities.
- Fix: update to 3.0.367 or later.
Description
Impact
Components could potentially allow cross-site scripting (XSS) in certain circumstances. These components could render content without adequate neutralization.
Patches
Fixed in 3.0.367.
NVD description
@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free