In short
- CVE-2022-24758 is a HIGH (CVSS 7.5) vulnerability affecting notebook, notebook (jupyter).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.8% of all vulnerabilities.
- Fix: update to 6.4.10 or later.
| Package | Affected versions | Patched versions |
|---|
| notebook PyPI | < 6.4.10
| 6.4.10
|
| notebook | < 6.4.10
| 6.4.10
|
Description
Anytime a 5xx error is triggered, the auth cookie and other header values are recorded in Jupyter server logs by default. Considering these logs do not require root access, an attacker can monitor these logs, steal sensitive auth/cookie information, and gain access to the Jupyter server.
Upgrade to notebook version 6.4.10
For more information
If you have any questions or comments about this advisory, or vulnerabilities to report, please email our security list [email protected].
Credit: @3coins for reporting. Thank you!
NVD description
The Jupyter notebook is a web-based notebook environment for interactive computing. Prior to version 6.4.9, unauthorized actors can access sensitive information from server logs. Anytime a 5xx error is triggered, the auth cookie and other header values are recorded in Jupyter server logs by default. Considering these logs do not require root access, an attacker can monitor these logs, steal sensitive auth/cookie information, and gain access to the Jupyter server. Jupyter notebook version 6.4.x contains a patch for this issue. There are currently no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free