In short
- CVE-2022-24771 is a HIGH (CVSS 7.5) vulnerability affecting forge (digitalbazaar), node-forge.
- Chance of exploitation in the next 30 days (EPSS): 0.78%, higher than 55.9% of all vulnerabilities.
- Fix: update to 1.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| forge | < 1.3.0
| 1.3.0
|
| node-forge npm | < 1.3.0
| 1.3.0
|
Description
Impact
RSA PKCS#1 v1.5 signature verification code is lenient in checking the digest algorithm structure. This can allow a crafted structure that steals padding bytes and uses unchecked portion of the PKCS#1 encoded message to forge a signature when a low public exponent is being used.
Patches
The issue has been addressed in node-forge 1.3.0.
References
For more information, please see
"Bleichenbacher's RSA signature forgery based on implementation error"
by Hal Finney.
For more information
If you have any questions or comments about this advisory:
NVD description
Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. Prior to version 1.3.0, RSA PKCS#1 v1.5 signature verification code is lenient in checking the digest algorithm structure. This can allow a crafted structure that steals padding bytes and uses unchecked portion of the PKCS#1 encoded message to forge a signature when a low public exponent is being used. The issue has been addressed in `node-forge` version 1.3.0. There are currently no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free