In short
- CVE-2022-24802 is a CRITICAL (CVSS 9.8) vulnerability affecting deepmerge-ts (deepmerge-ts project), deepmerge-ts.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.0% of all vulnerabilities.
- Fix: update to 4.0.2 or later.
Description
deepmerge-ts is used to merge 2 or more objects respecting type information. deepmerge-ts is vulnerable to Prototype Pollution via file deepmerge.ts, function defaultMergeRecords(). A fix was released in version 4.0.2. Currently, there is no known workaround.
NVD description
deepmerge-ts is a typescript library providing functionality to deep merging of javascript objects. deepmerge-ts is vulnerable to Prototype Pollution via file deepmerge.ts, function defaultMergeRecords(). This issue has been patched in version 4.0.2. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free