In short
- CVE-2022-24827 is a HIGH (CVSS 8.1) vulnerability affecting com.yahoo.elide:elide-datastore-aggregation, elide (elide).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.4% of all vulnerabilities.
- Fix: update to 6.1.4 or later.
Description
Impact
When leveraging the following together:
- Elide Aggregation Data Store for Analytic Queries
- Parameterized Columns (A column that requires a client provided parameter)
- A parameterized column of type TEXT
There is the potential for a hacker to provide a carefully crafted query that would bypass server side authorization filters through SQL injection. A recent patch to Elide 6.1.2 allowed the '-' character to be included in parameterized TEXT columns. This character can be interpreted as SQL comments ('--') and allow the attacker to remove the WHERE clause from the generated query and bypass authorization filters.
Patches
A fix is provided in Elide 6.1.4.
Workarounds
The vulnerability only exists for parameterized columns of type TEXT and only for analytic queries (CRUD is not impacted). Workarounds include leveraging a different type of parameterized column (TIME, MONEY, etc) or not leveraging parameterized columns.
For more information
If you have any questions or comments about this advisory:
NVD description
Elide is a Java library that lets you stand up a GraphQL/JSON-API web service with minimal effort. When leveraging the following together: Elide Aggregation Data Store for Analytic Queries, Parameterized Columns (A column that requires a client provided parameter), and a parameterized column of type TEXT. There is the potential for a hacker to provide a carefully crafted query that would bypass server side authorization filters through SQL injection. A recent patch to Elide 6.1.2 allowed the '-' character to be included in parameterized TEXT columns. This character can be interpreted as SQL comments ('--') and allow the attacker to remove the WHERE clause from the generated query and bypass authorization filters. A fix is provided in Elide 6.1.4. The vulnerability only exists for parameterized columns of type TEXT and only for analytic queries (CRUD is not impacted). Workarounds include leveraging a different type of parameterized column (TIME, MONEY, etc) or not leveraging parameterized columns.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free