In short
- CVE-2022-24847 is a HIGH (CVSS 7.2) vulnerability affecting org.geoserver:gs-main, geoserver (osgeo).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.2% of all vulnerabilities.
- Fix: update to 2.20.4, 2.19.6 or later.
| Package | Affected versions | Patched versions |
|---|
| org.geoserver:gs-main Maven | ≥ 2.20.0, < 2.20.4< 2.19.6
| 2.20.42.19.6
|
| geoserver | ≥ 2.20.0, < 2.20.4< 2.19.6
| 2.20.42.19.6
|
Description
Impact
The GeoServer security mechanism can perform an unchecked JNDI lookup, which in turn can be used to perform class deserialization and result in arbitrary code execution. The same can happen while configuring data stores with data sources located in JNDI, or while setting up the disk quota mechanism.
In order to perform any of the above changes, the attack needs to have obtained admin rights and use either the GeoServer GUI, or its REST API.
Patches
The lookups are going to be restricted in GeoServer 2.21.0, 2.20.4, 2.19.6.
Workarounds
Protection can be achieved by making the GUI (geoserver/web), the REST configuration (geoserver/rest) and the embedded GeoWebCache configuration (geoserver/gwc/rest) unreachable from remote hosts, in addition to protecting access to the file system where the GeoServer configuration is stored.
NVD description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The GeoServer security mechanism can perform an unchecked JNDI lookup, which in turn can be used to perform class deserialization and result in arbitrary code execution. The same can happen while configuring data stores with data sources located in JNDI, or while setting up the disk quota mechanism. In order to perform any of the above changes, the attack needs to have obtained admin rights and use either the GeoServer GUI, or its REST API. The lookups are going to be restricted in GeoServer 2.21.0, 2.20.4, 1.19.6. Users unable to upgrade should restrict access to the `geoserver/web` and `geoserver/rest` via a firewall and ensure that the GeoWebCache is not remotely accessible.
More vulnerabilities in org.geoserver:gs-main
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free