In short
- CVE-2022-24980 is a HIGH (CVSS 7.5) vulnerability affecting kitodo/presentation, kitodo.presentation (kitodo).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.3% of all vulnerabilities.
- Fix: update to 3.2.3, 3.3.4, 2.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| kitodo/presentation Packagist | ≥ 3.0.0, < 3.2.3≥ 3.3.0, < 3.3.4< 2.3.2
| 3.2.33.3.42.3.2
|
| kitodo.presentation | ≥ 3.0.0, < 3.2.3≥ 3.3.0, < 3.3.4< 2.3.2
| 3.2.33.3.42.3.2
|
Description
An issue was discovered in the Kitodo.Presentation (aka dlf) extension before 2.3.2, 3.x before 3.2.3, and 3.3.x before 3.3.4 for TYPO3. A missing access check in an eID script allows an unauthenticated user to submit arbitrary URLs to this component. This results in SSRF, allowing attackers to view the content of any file or webpage the webserver has access to.
NVD description
An issue was discovered in the Kitodo.Presentation (aka dif) extension before 2.3.2, 3.x before 3.2.3, and 3.3.x before 3.3.4 for TYPO3. A missing access check in an eID script allows an unauthenticated user to submit arbitrary URLs to this component. This results in SSRF, allowing attackers to view the content of any file or webpage the webserver has access to.
More vulnerabilities in kitodo/presentation
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free