In short
- CVE-2022-25024 is a HIGH (CVSS 7.5) vulnerability affecting json2xml, json2xml (vinitkumar).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.8% of all vulnerabilities.
- Fix: update to 3.14.0 or later.
| Package | Affected versions | Patched versions |
|---|
| json2xml PyPI | < 3.14.0
| 3.14.0
|
| json2xml | ≤ 3.12.0
| No fix yet |
Description
The json2xml package for Python allows an error in typecode decoding enabling a remote attack that can lead to an exception, causing a denial of service.
NVD description
The json2xml package through 3.12.0 for Python allows an error in typecode decoding enabling a remote attack that can lead to an exception, causing a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free