In short
- CVE-2022-2514 is a MEDIUM (CVSS 6.1) vulnerability affecting fava, fava (fava project).
- Chance of exploitation in the next 30 days (EPSS): 0.87%, higher than 59.1% of all vulnerabilities.
- Fix: update to 1.22 or later.
| Package | Affected versions | Patched versions |
|---|
| fava PyPI | < 1.22
| 1.22
|
| fava | < 1.22
| 1.22
|
Description
The time and filter parameters in Fava prior to v1.22 are vulnerable to reflected cross-site scripting due to the lack of escaping of error messages which contained the parameters in verbatim.
NVD description
The time and filter parameters in Fava prior to v1.22 are vulnerable to reflected XSS due to the lack of escaping of error messages which contained the parameters in verbatim.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free