In short
- CVE-2022-25171 is a CRITICAL (CVSS 9.8) vulnerability affecting p4 (p4 project), p4.
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.6% of all vulnerabilities.
- Fix: update to 0.0.7 or later.
| Package | Affected versions | Patched versions |
|---|
| p4 | < 0.0.7
| 0.0.7
|
| p4 npm | < 0.0.7
| 0.0.7
|
Description
The package p4 before 0.0.7 is vulnerable to Command Injection via the run() function due to improper input sanitization
NVD description
The package p4 before 0.0.7 are vulnerable to Command Injection via the run() function due to improper input sanitization
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free