In short
- CVE-2022-25185 is a MEDIUM (CVSS 5.4) vulnerability affecting org.jenkins-ci.plugins:generic-webhook-trigger, generic webhook trigger (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.66%, higher than 51.5% of all vulnerabilities.
- Fix: update to 1.82 or later.
Description
Jenkins Generic Webhook Trigger Plugin 1.81 and earlier does not escape the build cause when using the webhook, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
NVD description
Jenkins Generic Webhook Trigger Plugin 1.81 and earlier does not escape the build cause when using the webhook, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
More vulnerabilities in org.jenkins-ci.plugins:generic-webhook-trigger
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free