In short
- CVE-2022-25191 is a MEDIUM (CVSS 5.4) vulnerability affecting io.jenkins.plugins:agent-server-parameter, agent server parameter (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.60%, higher than 48.8% of all vulnerabilities.
- Fix: update to 1.1 or later.
Description
Jenkins Agent Server Parameter Plugin 1.0 and earlier does not escape parameter names of agent server parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
NVD description
Jenkins Agent Server Parameter Plugin 1.0 and earlier does not escape parameter names of agent server parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
More vulnerabilities in io.jenkins.plugins:agent-server-parameter
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free