In short
- CVE-2022-25238 is a MEDIUM (CVSS 5.4) vulnerability affecting silverstripe/framework, framework (silverstripe).
- Chance of exploitation in the next 30 days (EPSS): 0.71%, higher than 53.4% of all vulnerabilities.
- Fix: update to 4.10.9 or later.
Description
SilverStripe Framework through 4.10.8 allows XSS, inside of script tags that can can be added to website content via XHR by an authenticated CMS user if the cwp-core module is not installed on the sanitise_server_side contig is not set to true in project code.
NVD description
Silverstripe silverstripe/framework through 4.10.0 allows XSS, inside of script tags that can can be added to website content via XHR by an authenticated CMS user if the cwp-core module is not installed on the sanitise_server_side contig is not set to true in project code.
More vulnerabilities in silverstripe/framework
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free