In short
- CVE-2022-25352 is a CRITICAL (CVSS 9.8) vulnerability affecting libnested (libnested project), libnested.
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.4% of all vulnerabilities.
- Fix: update to 1.5.2 or later.
Description
The package libnested before 1.5.2 are vulnerable to Prototype Pollution via the set function in index.js. Note: This vulnerability derives from an incomplete fix for CVE-2020-28283
NVD description
The package libnested before 1.5.2 are vulnerable to Prototype Pollution via the set function in index.js. **Note:** This vulnerability derives from an incomplete fix for [CVE-2020-28283](https://security.snyk.io/vuln/SNYK-JS-LIBNESTED-1054930)
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free