In short
- CVE-2022-25354 is a CRITICAL (CVSS 9.8) vulnerability affecting set-in (set-in project), set-in.
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 80.0% of all vulnerabilities.
- Fix: update to 2.0.3 or later.
| Package | Affected versions | Patched versions |
|---|
| set-in | < 2.0.3
| 2.0.3
|
| set-in npm | < 2.0.3
| 2.0.3
|
Description
The package set-in before 2.0.3 is vulnerable to Prototype Pollution via the setIn method, as it allows an attacker to merge object prototypes into it. Note: This vulnerability derives from an incomplete fix of CVE-2020-28273
NVD description
The package set-in before 2.0.3 are vulnerable to Prototype Pollution via the setIn method, as it allows an attacker to merge object prototypes into it. **Note:** This vulnerability derives from an incomplete fix of [CVE-2020-28273](https://security.snyk.io/vuln/SNYK-JS-SETIN-1048049)
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free